Speedzilla Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,453 Posts
Discussion Starter #1
I have a 2004 Suzuki Jr50. I bought it brand new in 2004 and never started. It has been sitting since waiting for my son to grow up.

Added Gas and Oil into the oil tank. Gas is on, choke is set, Kick it over wont start. Does not even sound like it wants to start. Cracked the screw at the bottom of the float bowl and we have gas. Gas is about a month old.

Checked spark and it is getting plenty.

Any great ideas before I clean out the brand new carburetor and adjust the float.

All the other info involved bikes that have been running for a period and things are all gummed up.
 

·
I'll fix it.
Joined
·
2,249 Posts
doesnt matter if you ran it or not, if the carb ever had fuel in it, it could be gummed up.

I ran into the same issue when I bought an unsold 06 minibike...the carb was filthy because the dealer had it running when it was setup.
 

·
Premium Member
Joined
·
914 Posts
This may sound crazy but to get my old JR50 to run I have to pressurize the tank (blow into the vent line) and turn the petcock to PRI. Then once it was running, I would release the pressure.
 

·
Registered
Joined
·
1,453 Posts
Discussion Starter #5
Idea

I will give that a try. Cheap and Free Fixes are better

Tore carbs apart twice, nothing inside, used compressed air and blew out everything.

Hit it with some starting fluid, nothing. Tested kill switch continuity.

I am thinking it is the coil or the spark plug.
 

·
Premium Member
Joined
·
1,929 Posts
You got spark, fuel and compression it has to go....one thing to check though!!

I worked at a Suzuki dealer back in 2001 and prepped a new JR50 one time and I think we got it running but it ran like shit...

why?

Pull off the header, there is a washer in there that restricts the hell out of it and it barely runs. May not be in your case, but whip that thing off and have a look!
 

·
Premium Member
Joined
·
914 Posts
I will give that a try. Cheap and Free Fixes are better

Tore carbs apart twice, nothing inside, used compressed air and blew out everything.

Hit it with some starting fluid, nothing. Tested kill switch continuity.

I am thinking it is the coil or the spark plug.
Plugs are cheap and cause all kinds of weird problems.
 

·
Registered
Joined
·
1,453 Posts
Discussion Starter #8
Washer

Mine definately has the washer installed. I was hoping to leave it there for a while so my son does not get to ambitous. If it ran like crap I would be looking at this. But it does not even give a hint of starting. Which sounds electrical.

New plug tommorow to replace the new plug that is in there.
 

·
Premium Member
Joined
·
1,929 Posts
I can't remember if it ran like crap or if we had to pull it out just to get it going...take it out and try to start it, you can always put it back in!

Good luck!
 

·
Registered
Joined
·
2,868 Posts
I love this stuff , takes me back , way back . Please tell us when you get the little zinger started .:rockon
 

·
Registered
Joined
·
1,453 Posts
Discussion Starter #11
Tonight

I am going to try the new plug and priming the system tonight.

Is there anyplace to download a free shop manual for this bike?
 

·
Registered
Joined
·
1,453 Posts
Discussion Starter #13
Its Alive

New Spark Plug.

Turned it to Prime, Blew in the vent and it started on the first kick.

Thanks for all the help. My kid was smiling from ear to ear.

Of course I was at Moon Motorsports today and they had a Honda 50 roadracer there.
 
1 - 14 of 14 Posts
Top