Speedzilla Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Life is never simple in the Macdonald household :rolleyes:

I had the exhausts and panels off to do a trial fit of a new endurance fairing and ti exhaust. While the bike was stripped down I fitted a Thorsten Cable Clutch Conversion and tried to set it up, testing it by starting the bike on a centrestand and putting it in gear. I later figured out it was easier on the bike to put it in gear and move it around with the engine off to test

Then I put the original panels and exhaust back on (keeping the CCC) and tried to start it again; it turns over but wont start :confused:

Fresh Battery
All lights come on
Fuel pump does its thing when turned on
Kill switch is set to "run"
The connectors for the clutch switch are not plugged in but I should be able to start and rev up to 5k shouldn't I

Erm not sure whet else is important - please ask away if you can help!!

Many thanks in advance,
Allan
 

·
Registered
Joined
·
250 Posts
When clutch or sidestand switches are activated the starter won't turn.
First check the basic's like sparks/fuel.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
In the OP I said nothing is ever simple in the Macdonald household. I was wrong, I must be as simple as they come :banghead


In future, when disconnecting the battery, I will REMEMBER TO REATTACH THE POWER COMMANDER EARTH WIRE BEFORE WHINING AND ASKING FOR HELP ON FORUMS ALL OVER THE PLACE :rolleyes:

Many thanks for the help, sorry for being such an epic tool :wacky

Cheers,
Al
 
1 - 8 of 8 Posts
Top