Speedzilla Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Hi Guys
I'm sure this topic will have been touched on sometime but please help if you can :) I just fitted a new seat hump, all the holes lined up great, I have a pyramid undertray and even the 2 holes in that went straight in no trouble at all, but when I fitted the removeable luggage compartment top the fit was shit, at one point i could even prize it open with my hand :eek: do any of you guys know the secret to getting it to fit tight, it presently moves side to side and is not flush on the top surface, I tried loosening the seat and dragging it about, but not much joy :banghead :banghead :banghead
 

·
Registered
Joined
·
191 Posts
A picture would probably help. I have no idea what a "seat hump" is, but I think you are referring to the rear compartment lid?

Eric
 

·
Registered
Joined
·
73 Posts
I had this happen to me with an ill-fitting undertail. Most likely, although your undertail/tray seemed to fit well with body-work, in fact it is off by a bit, that is why the cover is out of whack.

Basically the fitment of the cover is like yourr last check that everything is fitted dead-on. If you are off by a bit, any mistake you made will show-up when you try to fit the cover.

Make sure that your undertray is not forcing the tail section upward and/or back/forwards by even a little bit. If so, try to readjust. I suggest putting it all together, then leave all the tail bolts loose until the cover fits right, then tighten everything up. It might be just that simple. More complicated is if you need to re-drill the unertray holes -- maybe they were off a bit.

Hope that makes some sense.
 
1 - 4 of 4 Posts
Top