Speedzilla Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
I have recently had my FI light come on. I am not sure why it is happening, but I can start the bike, ride without it on, then eventually the bike will stall out when I am coming to a stop and the FI light comes on when I start it up. When it is on I get a lot more backfire after acceleration? I read my manual about the FI light supposed to blink and tell me what is wrong with it, but it is not blinking, it is just ON. Any help would be great as the other alternative is to bring it to the dealer. Thank you

Jesse
2000 rc51.
 

·
Enormous Member
Joined
·
1,460 Posts
jesse_k said:
I have recently had my FI light come on. I am not sure why it is happening, but I can start the bike, ride without it on, then eventually the bike will stall out when I am coming to a stop and the FI light comes on when I start it up. When it is on I get a lot more backfire after acceleration? I read my manual about the FI light supposed to blink and tell me what is wrong with it, but it is not blinking, it is just ON. Any help would be great as the other alternative is to bring it to the dealer. Thank you

Jesse
2000 rc51.

Remove the seat and open up the battery cover, using a 10 mm open end wrench, tighten the ground and positive leads on the battery. you are good to go.

the next thing you will need to do is tighten all the hose clamps as you will notice a smallamount of coolent odor when you ride for more then 15 minutes.
 
1 - 2 of 2 Posts
Top