Speedzilla Forums banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
can someone please give me some clues as to why I loose power momentarily under hard acceleration? Could it be that my battery cable may be frayed. Checked it for the most part, seemed OK. Has anyone experienced something like this. Could the PC3r cause this. Oh yeah the FI light does show up momentarily. I have tried to
 
G

·
Discussion Starter · #2 ·
is it more of a hesitation? The map on the dynojet could cause it. Dirty plugs, dirty injectors... try leaning out the mixture in the rpm that its laging it. It might be running to rich
 
G

·
Discussion Starter · #3 ·
Re: Power Loss. (sherrc51)

Sherr I know you looked at this but look again


The Battery cables are losing contact. Either at the battery or at the ground.

or

Look for a short or break in the leads in the main harness under the rear of the gas tank

one of these 3 points will probably hold the problem.

The Main Harness problem is a real pain to find, ( I looked at mine several times and failed to find the broken wire, A good friend that is also a professional mechanic grabbed the lead and found it in 30 seconds)
 
G

·
Discussion Starter · #4 ·
Re: Power Loss. (sp2pilot)

I have looked at the main harness and also checked the pc3r. Matter of fact i disconnected the pc3. The battery terminals are all good. Changed the spark plugs. Checked everything. The power loss is less than a second long but just scarry. I am just lost. Then a friend puts more coolant in the bike bucause he said it was hot, and low and behold, it hit 253 and puff of smoke and shut off. I think i found the prob. Coolant top loose. Heat prob was solved, but not the FI.
 
G

·
Discussion Starter · #5 ·
Re: Power Loss. (sherrc51)

my 2000 is doing that 2. the problems is the pc3. i have talk to other friends with
rc and they told me that all they did was change the pc3 and they never had that problem. i am going to order a new pc3 with usb. i dont know if that is going to fix your problem.

good luck
 
G

·
Discussion Starter · #6 ·
Re: Power Loss. (600killer)

I took off the pc and still have the same prob. I am now checking all other connections.
 
G

·
Discussion Starter · #7 ·
Re: Power Loss. (sherrc51)

i looked into my bike this weekend and i found that the pos cable on the battery was not on right.
 
1 - 8 of 8 Posts
Top