Speedzilla Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi there.

I posted my snowmobile for sale or trade for a streetbike. Guy offered me a 2001 SP1 with 49,000 km on it.

So I did the deal.

When I checked it, it started up right away. Now I haven't managed to start it but the battery is low, so charging right now. See what happens tomorrow. Kid I got it from bought it as his first bike, then realized his mistake before doing any damage to it.

Otherwise, seems nice. Fairings are about 8/10, has some sort of Ti high mount exhaust on it, has passenger pegs delete, seems to have an aftermarket rear shock (will ID it tomorrow).

Thinking of parting it out, or just riding it.

Need to get $3500 cdn for it, (about 2900 US). What's the best way to do that?
 

·
calculating status...
Joined
·
1,667 Posts
So this is should be in the classifieds?

And no photos? What the hell man.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
More asking for advice here. Actually, I am liking it. I might keep it for a while. It's very hard to start. Should I check the plugs?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I will post a picture of the plugs. Short answer, they are shot. I have no idea how the PO ran it before...
 

·
Registered
Joined
·
259 Posts
Battery...
I concur....
Low compression engine, 87 octane fuel 2 year old spark plugs..
HOT/charged battery.. fires right up....
When you go to put spark plugs , price per plug is $15-$20 a plug..:surprise:
You get the battery hot, ride the bike, you like it... or not....:grin2:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Got new spark plugs. Ordered them off ebay, but wanted to ride sooner, so went to local dealer. He had 2 plugs. I have no idea why a Honda/Yamaha/Harley dealer in the middle of nowhere would stock plugs that were only ever used on one model for 2 years, but enh. He of course raped me good on the price ($37 cdn each:confused:).

But, put the plugs in and it fired up no problem. Took it for a ride.

Brakes didn't work. How did I miss that massive fork leak all over the brakes?

So, caliper off, brake cleaner all over the caliper, pads out, cleaned with brake cleaner then torched. Back in. Now there are enough brakes (barely) to ride. It will lock up the front if you squeeze it really hard, but needs new pads. Ordered new pads on ebay and will wait until they come.

Ok, checking lights. Brake light is only working on one side, and is bright when brakes are off, dim when they are on. Hmm.

PO put on a tail tidy with one of those retarded chinese LED tail lights. And it's dying. If I could find a stock tail and tail light, i would jump on it, but it looks like i will just be replacing the lame Chinese tail light with another lame Chinese tail light.

I don't mind modding my own bike but I hate having to deal with someone else's abortion.

Right now I would love to have back the stock exhausts, tail, passenger pegs, pad and tail light but that's probably not going to happen.

As for riding it. Engine is working very well. Has slightly less power than my old ZX9R, but a lot more power in the lower rev ranges. Far easier to lean and turn. Way less comfortable to ride, even with the aftermarket seat.

Has a race clutch in it, which is really really grabby. Something to get used to, but along with the lightswitch throttle will take some getting used to.

If I keep it I may go smaller on the rear sprocket.
 
1 - 11 of 11 Posts
Top