Speedzilla Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
947 Posts
Discussion Starter #1
i got a set of those ebay wave rotors last year and thought they were about like stock as far as stopping goes, well... took them to the track yesterday for the first time and when braking hard they started making a little bit of noise like the brakes on a semi make, like they're vibrating or something... not exactly sure what would cause it, but anyways... when it did that, they didn't seem to be working as efficient, so i yanked on the lever harder and that was a bad idea.

apparently, when you hear that noise on those things, it's the limit...:woot: and trying to stop any harder will result in grabbing like it slips grabs slips grabs and the grab part is where your front tire is locking up. they seemed to have been ok on the street, but keep them away from the track.

my box 'o junk in the garage now has two more items occupying it
 

·
Premium Member
Joined
·
914 Posts
i got a set of those ebay wave rotors last year and thought they were about like stock as far as stopping goes, well... took them to the track yesterday for the first time and when braking hard they started making a little bit of noise like the brakes on a semi make, like they're vibrating or something... not exactly sure what would cause it, but anyways... when it did that, they didn't seem to be working as efficient, so i yanked on the lever harder and that was a bad idea.

apparently, when you hear that noise on those things, it's the limit...:woot: and trying to stop any harder will result in grabbing like it slips grabs slips grabs and the grab part is where your front tire is locking up. they seemed to have been ok on the street, but keep them away from the track.

my box 'o junk in the garage now has two more items occupying it
Whom on ebay did you get them from? Just trying to figure out which ones to stay clear of. It sounds like you did not go down, that is good but the possibility could have been very bad.
 

·
Dr. Carbon
Joined
·
2,974 Posts
I had a similar problem on a 99 zx6r with the stock rotors after track use. The rotors would resonate and the front end would shutter but the braking force never seemed to be that much, or as much as it used to be. I was never able to resolve the issue. the rotors were nither warped nor pitteed etc....
 

·
Registered
Joined
·
947 Posts
Discussion Starter #4
Whom on ebay did you get them from? Just trying to figure out which ones to stay clear of. It sounds like you did not go down, that is good but the possibility could have been very bad.
luckily i was going straight when it happened so it didn't wash out, for the rest of the day i rode in the back as a precaution so i didn't take someone else out with me. as for the seller, i'm not sure, those things all come from the same manufacturer, the no-name brand chinese wave rotors are sold by dozens of people on there

@ dr. carbon i was thinking this was possibly because of the material used in the rotor itself because this happened on the second lap of the first time they had ever been on the track, the first lap we were just putting around and they sure haven't seen any abuse on the street
 
1 - 4 of 4 Posts
Top