Speedzilla Forums banner

1 - 3 of 3 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Rode to work today and rolling up to the gate guard to show my ID I couldn't find neutral........so in an attempt to speed the process I turned the bike off to free my hands to pull out my wallet. With that done I go to start bike and find I have absolutely no electrical power at all with key on
So I push bike out of the way and start looking for the obvious to no avail. finally after about 20 minutes of dickin around walla! Don't know what I did but it worked.......So off I go no problems right! Well now works done and I head home making several stops with no problems at all, I make it home turn of bike and go to try it one more time and same problem....no power at all! So out comes the volt meter and wire diagram thinking I have a bad fuse or ignition switch I shoot all the wires and find them good I then trace wires to the start relay burried under the dash and there I find the sourse of my problem..... the relay had come loose
So moral to this story is take a few minutes to study your wire diagrams and learn where everything is....lucky for me the last place the bike died was my garage......had I been out on a ride it could have been costly $$ for such a simple dumb ass fix!
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Re: Bike Died today (bruntr)

Thanks for the advice, sounds like something I need to do on a rainy day


-Tifosi
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Re: Bike Died today (Tifosi)

here here !!! i'll be looking at that tonight
 
1 - 3 of 3 Posts
Top