Speedzilla Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I hope someone can give me a little direction on this one. My bike sat for a little over a month and then didn't start...battery right. So I jumped it and it started right up but the electronics were all goofy. I only had instruments and dash lights when I applied the front break, had front marker lights but no rear and the blinkers didn't work at all. I shut it off and it was dead again, not even enough juice to get a head light. I pulled the battery and it tested good even under load? All the fuses are good too. Let me also point out that this 98 is cherry and stock, anybody know what else I can check?
 

·
Registered
Joined
·
143 Posts
Wait...
Battery tests good on load test & is putting out 12 volts at rest?
Still sounds like a low voltage problem to me.

Start with the basics.
Check all your ground connections....battery & frame.
Clean and sand if necessary to get good metal to metal contact on ALL your grounds.
Next check all the positive connection points.
Start the bike and check the charging system.
It should be putting out about between 13.5-14.5 volts at the battery. (check with your volt meter at the battery)
I have read reports the R/R (voltage regulator) goes bad on these bikes.
If you are not getting 13-15 volts from the charging system I would suspect the R/R unit bad & you should run tests on that (tests are in the manual)
You do have a shop manual for the bike....right?
Try these things & let us know what you find.
Bill
 

·
Registered
Joined
·
5 Posts
Did you jump the bike with a car or truck ?? was the car or truck running? because if you did you fried some stuff!!! TPI/CDI box is probably shot, rectifier is definately shot. Check the rectifier and the CDI !!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 · (Edited)
Thanks for your help, as it turns out the bone head that tested my battery was a bone head. A new battery solved all my problems and I'm back on the road good as new!
 

·
Registered
Joined
·
143 Posts
Cool.... Glad you are back on the road. It's really nice riding weather right now :)
 
1 - 5 of 5 Posts
Top