Speedzilla Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
412 Posts
Discussion Starter · #1 ·
The ol'pig left me walking today for the first time since I bought her. I own a 2000 Rc51 with some where around 18k miles. I got her out today to run to the bank and deposit my check. All was well till on the way home she all of a sudden dropped a cylinder and about 5 sec later died and would not start. It happened after a long mid rpm decell down a hill with a turn at the bottom. I turned the corner and upon accel everything went to crap. I called for a ride and loaded it up. By the time I got it back home (maybe an hour) and unloaded her, she started back up!!! WTF? :wtf. Any ideas? There was a little smoke coming from the exhaust, and some fluid that was seeping from an exhaust joint directly under the foot pegs. I don't think it was oil, maybe fuel. That fluid quickly dried/burnt off and now runs like it always has. What could have possibly gone wrong?:banghead If the thing just quit and did not start back up I could trouble shoot till I find the bad part. Now it's running again and I have no idea what happened.......:wtf:mad:

I recently changed the oil and installed new plugs. I also had just filled with fuel. No FI light. The thing was running great till..........
 

·
Registered
Joined
·
412 Posts
Discussion Starter · #3 ·
I don't have a PC2 or 3. I have the Yosh EMS computer. Think it could be the problem?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top