Speedzilla Motorcycle Message Forums - Reply to Topic
Thread: slipping clutch Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Speedzilla Motorcycle Message Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-14-2006 04:02 PM
carlo's sp1
Quote:
Originally Posted by bafflebrain
First of all, what oil did you use last?

I would not rule out you using car oil with friction modifier.
the last oil change was with a honda dealer when it was serviced in september ....I assume he would know what oil to use
12-14-2006 02:16 PM
dhdrider It might be your clutch, though. I had a 2000 RC that I turned into a track bike and the previous owner ragged the hell out of it. I am assuming terrible wheelies & starting methods. Several of the clutch plates were broken. You can look at all your clutch plates w/o draining your oil. Just put it on the sidestand and pull the clutch cover. The oil level is well below the bottom of that cover. If you do have broken plates, then you know you have to change your oil anyway.
12-13-2006 11:15 PM
beaugator +1 on the moly in the oil.. it will build up on the clutch plates and cause it to slip.


Quote:
Originally Posted by bafflebrain
First of all, what oil did you use last?

I would not rule out you using car oil with friction modifier.
12-13-2006 11:03 PM
bafflebrain First of all, what oil did you use last?

I would not rule out you using car oil with friction modifier.
12-13-2006 10:18 PM
jamntlr
Quote:
Originally Posted by ZeKers
What kind of sounds are you getting? Also the life of the clutch depends on how you treat it. I would think that if you change your oil regulary and don't clutch the front wheel up everwhere you ride that it should last longer than 12k miles. You may have glazed the plates which happened to my SV before I had purchased it. When the motor and clutch was cold it would "Chatter" some times until it got warm. My SV only had 2k miles on it at that time and now I have close to 15k and she still rides like a champ and no problems with the clutch this far.


Only 12k Hell I have 93,000 miles on my Stock clutch from commuting, I dont do too many wheelies and I have had all secheduled services done. My shit doesnt slip at all.
12-13-2006 07:45 PM
carlo's sp1 you are correct 2002 would be an sp-2 over here to but this sp-1 was registered in 2002,not by me but the guy i got it from
12-13-2006 07:22 PM
BC51
Quote:
Originally Posted by carlo's sp1
...i got my 02 sp1....
Contradictory statement.

2002 RC51 is an SP-2 (at least in North America. You guys ride on the wrong side of the road so it may be different there. )
12-13-2006 07:07 PM
carlo's sp1 because thats what it is
12-13-2006 07:02 PM
RVTMAVERICK
Sp2...

You got it, let us know what you see/hear

Oh yeah, why are you calling her SP1?


Peace Jeff



Quote:
Originally Posted by carlo's sp1
Hi Jeff,i will give it a try thanks
12-13-2006 06:50 PM
carlo's sp1 Hi Jeff,i will give it a try thanks
12-13-2006 06:30 PM
RVTMAVERICK
1st Off 2002 RC51

Is a SP2!

2nd, I don't understand HOW anyone could NOT know when their clutch IS slipping or NOT You have a "tach" on that MC don't you!....??? Here's the answer to your question, next ride when you know about where you think you have the problem, just before look at your Tach, then hit the gas, if your tach readings RPM's start jumping up faster then you are accelerating, well then your clutch is slipping, if not it's not.

I Hope This Helps....


Peace Jeff
12-13-2006 05:22 PM
carlo's sp1 there is no clattering noise ,no wheelies off the clutch,oil gets changed regulary,the only noise i am getting is when i open her up hard it just sounds like its slipping,(it could just be my hearing giving me s**t or old age)the clutch also only bites when the leaver is nearly right out....
12-13-2006 05:09 PM
ZeKers What kind of sounds are you getting? Also the life of the clutch depends on how you treat it. I would think that if you change your oil regulary and don't clutch the front wheel up everwhere you ride that it should last longer than 12k miles. You may have glazed the plates which happened to my SV before I had purchased it. When the motor and clutch was cold it would "Chatter" some times until it got warm. My SV only had 2k miles on it at that time and now I have close to 15k and she still rides like a champ and no problems with the clutch this far.
12-13-2006 04:57 PM
carlo's sp1
slipping clutch

Hi Guy's,i got my 02 sp1 in feb this year with 8000 miles on the clock it had no power commander, standard 16 tooth front sproket.It now has the commander on with a 15 sproket and has now done 11500 miles....The problem i am getting to is that it sounds like the clutch mabe slipping,Any ideas how long they are suposed to last ?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome