996 Fuel Injectors/Throttle Body question - Speedzilla Motorcycle Message Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-08-2015, 08:19 PM Thread Starter
Member
 
Join Date: Jun 2006
Location: Lafayette, CO
Posts: 49
996 Fuel Injectors/Throttle Body question

I have a 748s chassis with a 996 transplant. Earlier this week she started but died a few seconds later and hasn't started since. If I spray some starter fluid into the carbs she'll start for a few seconds so I'm pretty sure it's a fuel supply issue and not electrical/relays/plugs. Fuel pump whines when I turn the key so I'm focusing south of the tank for now.

Now that I have the tank and airbox off I'm a little confused at what I'm looking at and the Haynes manual isn't helping. The throttle bodies have 4 injectors (green heads) but only 2 of them have electrical connections. Should I clean/replace all 4 injectors or are the 2 that have electrical connectors the only ones that are actually doing work?

Any other usual suspects that I'm not thinking of?
designmethod is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-10-2015, 01:26 AM
Senior Member
 
rjjablo's Avatar
 
Join Date: Sep 2006
Location: Shoreview MN
Posts: 1,453
Tank

Pull your tank and make sure fuel lines are not split.

Did it run before you transplanted Motor and fuel Injection?

Throttle bodies are from which Bike?
rjjablo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Speedzilla Motorcycle Message Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome