Monster S4 2001: Icu Problem, Bike Doesn't Start - Speedzilla Motorcycle Message Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-23-2016, 08:18 AM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Singapore
Posts: 1
Monster S4 2001: Icu Problem, Bike Doesn't Start

Hi everyone,

I would be grateful for some advice. I am a newbie the forum and to the Ducati world. I live in Singapore and bought my first Ducati in March, a beautiful S4 (2001 model, carburetor).

About a month or so ago, I switched it off and when i tried to switch it back on after literally 30 seconds, it just would not start. It cranked for a second and stopped.

The shop tested everything and said the Immobilizer may be faulty. I got a second hand ICU from ebay but it doesnt work as it has to be flashed with my current system.

I have been told i have the following options:
1) Get a new ICU, ECU, key ignition panel & keys. cost approx US$3000 +
2) I can get a new ICU, flash the whole system and get it to work

I dont want to go for option 1 if there is a cheaper way. For option 2, the workshop says they need the bin file for my model but cant find it. Is there any suggestion or advice you can give me to help me out?

Regards,
Monster Mania
Monster Mania is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-24-2016, 06:46 AM
Junior Member
 
DucMo's Avatar
 
Join Date: Aug 2002
Location: NBH, NBH
Posts: 26
There is no Monster S4 w/ carburetor MY2001.

Please be more specific in your model description, because they
changed the ecu during model life of the S4. Do you have
an digital speedo?

Have here several bin files for different Monster ecus.

cheers,
horst

shit stops when the lights go out,
horst
--

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
DucMo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Speedzilla Motorcycle Message Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome